log in | register | forums
Show:
Go:
Forums
Username:

Password:

User accounts
Register new account
Forgot password
Forum stats
List of members
Search the forums

Advanced search
Recent discussions
- !OBrowse reviewed (News:10)
- Aemulor (Gen:16)
- DDE reaches release 28 and above (News:)
- Elesar quicks dispels stormy clouds (News:2)
- RISC OS London Show 2017 - Notes from the talks (News:2)
- RISC OS London Show 2017 (News:)
- RISC OS London Show 2017 - Pictures (News:)
- October News (News:2)
- Retrospective thoughts on 12 months of Titanium ownership (News:4)
- RISC OS London Show 2017 (News:1)
Related articles
- Games FAQ
- SunBurst hints, tips and walkthrough
- Angband support - A Beginner's Guide - Part 3
- Angband support - A Beginner's Guide - Part 1
- Angband support - Introduction
- Angband Support - Questions and Answers
- Angband supprt - A Beginner's Guide - Part 2
- Doom - Cheat Codes
- Humorous and painful Quake moments
- Destiny Hints and Tips
Latest postings RSS Feeds
RSS 2.0 | 1.0 | 0.9
Atom 0.3
Misc RDF | CDF
Site Search
 
Article archives
Acorn Arcade forums: News and features: RailPro - FAQ
 

RailPro - FAQ

Posted by Alasdair Bailey on 00:00, 30/10/2000 | , ,
 

This page contains some frequently asked questions about the playing of the game RailPro. The questions and answers were contributed by the author of the game, Jos.
 



 

Q: When having defined the stations and viewing all the data with option 8 in !RailEdPro, the first station is blank and looks as if it hasn't been defined.
 

A: This may occur when you use option 8 before any station has been defined. Not sorted out yet why this happens. To 'repair' the definition of the first station, you have to do the following things:

  1. Choose option 5 in the main menu and then 1 (blank 1st station);
  2. Choose 5 (rename) and give the name and code of the station;
  3. Choose 1 (coord) and redo the coordinates of the station;
  4. Choose 2 and give the lowest and highest platform-numbers; (When you've done this, you'll see in the overview that all platforms still have the initially defined numbers. Press return to leave them intact until you leave this option). It should all be visible now in the data-overview and working well in !RailPro.
     



    Q: I created a map. When a train is announced, the game stops and I get the error 'Sprite doesn't exist at line..'. What's the problem?


    A: The cause will be, that you put a letter or number directly behind an entrypoint. Leave one or two cells empty behind the entrypoint. Letters and numbers are not defined in the Sprites-file, but have a different coding. When the last part of a train is on top of that and moving to the next cell, it can't restore the original sprite. It is okay to put letters/numbers behind an exitpoint.




    Q: I have a 'through'-station and on the left of that another station that can be reached via a 180 degree bend. To reach that station, the train first has to go to the right, but it doesn't do that by itself, only by manual redirecting.


    A: At a 'through'-station (signals on both sides of the platforms) a train will always head to the direction where another station or exitpoint is situated. Only at platforms with a buffer a train will immediately go into the opposite direction. In this case you will have to change some track (leave out the bend), so that the train can travel to the left to that second station.
     



    Q: I have a map with suburban platforms, but LP-trains don't stop.

    A: If signals (sub or main) are attached to a suburban platform, a LP-train will always stop there, regardless of the signal-color. IC's will only stop when they meet a red signal at a suburban platform. Check if signals are attached.



    Q: My GD-trains do not get a new departure-time at the depot. Why not?


    A(1): You didn't use the correct type of depot-track. For IC's and LP's you need to use the blue-tiled platforms in depots/ maintenance-sidings, for GD's the track with the black lined extensions. Look at some supplied maps to see the difference.


    A(2): The coordinates of the depot-area are not correct. The bottom-left marker has to be placed somewhere below the utterleft buffer/signal, whilst the top-right marker has to be placed somewhere above the utter-right buffer/signal of the station/depot-area.
     



    Q: When a train arrives at a certain platform of my map, the game hangs.


    A: When defining platforms, you always have to watch if the exitpoints from that platform allow the type of train (IC,LP) that's on. If platform 1 has exits to destinations that accept LP's only, an IC arriving on that platform will not be able to get a new destiny (and hang the game). You either have to change the entrypoint to accept IC's as well on exit, or change the platform-access for some entrypoints. When using maintenance-sidings, extra care has to be taken for the platforms at the first defined (main) station.
     



    Q: Where do I leave empty trains?


    A: Empty trains can be left on any part of the track that has some signals and where a sided train won't be in the way of the normal train-traffic. When creating a map, put in some extra tracks (as a siding) to store up to four empty trains.
     

Log in to comment on this article

Acorn Arcade forums: News and features: RailPro - FAQ